Issue with Page Speed Reports
Incident Report for Pingdom

We experienced an issue during a deploy that resulted in the Page Speed reports not loading.

The Outage

Note: All times referenced below are Coordinated Universal Time (UTC).

At 09:26 our dev team deployed a fix for My Pingdom to improve site performance.

Shortly thereafter they noticed issues with accessing the Page Speed reports and started investigating the issue. They tracked the issue down to a minor mistake in the deploy configuration.

Service restoration was reported at 09:50, although we continued to monitor the situation. We saw no impact on Uptime monitoring or alerting, and data was still being collected by the Page Speed reports.

No data is missing from the Page Speed reports as the issue was simply a communication error between the reports and the data available.

Posted 6 months ago. Jan 03, 2017 - 13:25 UTC

Resolved
The issue has now been resolved and everything is back up and running. Post-mortem to follow.
Posted 6 months ago. Jan 03, 2017 - 10:01 UTC
Investigating
We're currently experiencing some problems with displaying Page Speed reports. Our devops team is investigating and we will return with an update in 30 minutes, or as the situation develops.

Please note that uptime monitoring or alerting is not affected and that page speed data is still being collected, just not displayed.
Posted 6 months ago. Jan 03, 2017 - 09:47 UTC